LightOj 1045 N!位数的应用

Digits of Factorial
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

题意:求N!在m进制下的位数

对于N!的位数求法,我之前写过一篇博文,这道题和之前的文章方法一样,只是加了一个换底公式。

求N!的位数求法  点击-> 传送门

对于非10进制的位数 只需把之前的N!= 10^m 才成N! = base^m (base表示进制)即可 

转化成 位数 m = log(base,N!) 对于这个的求解 需要用到换底公式 转化成 m = log(N!) / log(base) 即可。

另外注意到 数据量比较大 所以需要 预处理 出 log(N!)

详细见如下代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=1000005;
double f[MAXN];
int main()
{
    f[0]=0;
    for(int i=1;i<MAXN;i++){
        f[i]=f[i-1]+log(1.0*i);
    }
    int T;
    scanf("%d",&T);
    for(int Case=1;Case<=T;Case++){
        int n,m;
        scanf("%d%d",&n,&m);
        int res=f[n]/log(1.0*m)+1;
        printf("Case %d: %d\n",Case,res);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值