Mondriaan's Dream
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 19607 | Accepted: 11143 |
Description
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

Sample Input
1 2 1 3 1 4 2 2 2 3 2 4 2 11 4 11 0 0
Sample Output
1 0 1 2 3 5 144 51205
一、原题地址
二、大致题意
在n*m的地板上铺满1*2的砖头,能有多少中铺法。这里的铺满是指全部填满没有空缺和重叠。
三、思路
对于每个格子,我们用0和1来表示他的状态。对于第i行j列的格子;
若砖头横着铺,我们令 [ i , j ]和[ i , j+1 ]都标记成1。
若砖头竖着铺,我们令 [ i , j ]为0,[ i+1 , j ]为1。
那么对于第i行砖头的铺法,我们就可以从第i-1行获得。
四、代码
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<list>
using namespace std;
const int INF = 0x3f3f3f3f;
#define LL long long int
long long gcd(long long a, long long b) { return a == 0 ? b : gcd(b % a, a); }
const int MAXN = (1 << 11) + 5;
int n, m;
LL temp[MAXN], dp[MAXN], bir[MAXN];
bool check(int i)
{
while (i)
{
if (i & 1)
{
i >>= 1;
if (!(i & 1))
return false;
i >>= 1;
}
else
i >>= 1;
}
return true;
}
void init()
{
memset(temp, 0, sizeof(temp));
for (int i = 0; i < bir[m]; i++)
{
if (check(i))temp[i] = 1;
}
}
void dfs(int k,int i,int j) //k表示当前处理第几位,j表示上一层可行的状态
{
if (k == m)
{
dp[i] += temp[j];
return;
}
if ((i >> k) & 1)
{
dfs(k + 1, i, j);
if ((i >> (k + 1)) & 1)
dfs(k + 2, i, j | (1 << k) | (1 << (k + 1)));
}
else dfs(k + 1, i, j | (1 << k));
}
void DP()
{
for (int i = 2; i <= n; i++)
{
for (int i = 0; i < bir[m]; i++)dp[i] = 0;
for (int i = 0; i < bir[m]; i++)dfs(0, i, 0);
for (int i = 0; i < bir[m]; i++)temp[i] = dp[i];
}
}
void Solve()
{
init();
DP();
printf("%lld\n", temp[bir[m] - 1]);
}
int main()
{
bir[0] = 1;
for (int i = 1; i < 12; i++)
bir[i] = (bir[i - 1] << 1);
while (scanf("%d%d", &n, &m), n && m)
{
Solve();
}
getchar();
getchar();
}