问题描述
给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
输入的第二行有n个整数s 1, s 2, …, s n (1 ≤ s i ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输入的第二行有n个整数s 1, s 2, …, s n (1 ≤ s i ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
10 1 10 20 30 20
样例输出
10
#include<iostream>
#include<map>
using namespace std;
int main()
{
int n;
cin >> n;
map<int, int> a;
int in;
for(int i=0; i<n; i++)
{
cin >> in;
a[in]++;
}
int maxtimes = 0; //出现最多的次数
int max_num = 0; //出现最多次数的数
for(map<int, int>::iterator it=a.begin(); it!=a.end(); it++)
{
if(maxtimes < it->second)
{
maxtimes = it->second;
max_num = it->first;
}
}
cout << max_num;
return 0;
}