A Knight’s Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38352 Accepted: 13017
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int vis[27][27];
int pre[27][27][2];
int n,m;
int T;
int ans[27][2];
int flag;
int di[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
bool can(int x,int y)
{
if(vis[x][y]) return 0;
if(x<=0||y<=0||x>m||y>n) return 0;
return 1;
}
void outt(int x,int y)
{
//cout<<x<<" "<<y<<endl;
int cnt=0;
while(x!=0)
{
cnt++;
ans[cnt][0]=x;
ans[cnt][1]=y;
int xx=pre[x][y][0];
y=pre[x][y][1];
x=xx;
//cout<<x<<" "<<y<<endl;
}
for(int i=n*m;i>=1;i--)
{
cout<<char(ans[i][0]-1+'A')<<ans[i][1];
}
cout<<endl;
}
void dfs(int x,int y,int cnt)
{
vis[x][y]=1;
cnt--;
if(flag) return;
if(cnt==0)
{
flag=1;
outt(x,y);
return ;
}
int mx,my;
for(int i=0;i<8;i++)
{
int mx=di[i][0]+x;
int my=di[i][1]+y;
if(can(mx,my))
{
pre[mx][my][0]=x;
pre[mx][my][1]=y;
dfs(mx,my,cnt);
}
}
vis[x][y]=0;
return ;
}
int main()
{
scanf("%d",&T);
for(int jj=1;jj<=T;jj++)
{
scanf("%d%d",&n,&m);
printf("Scenario #%d:\n",jj);
memset(vis,0,sizeof(vis));
flag=0;
int cnt=n*m;
dfs(1,1,cnt);
if(flag==0) printf("impossible\n");
printf("\n");
}
}