7-15 QQ帐户的申请与登陆(map)

输入样例:

5
L 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
L 1234567890 myQQ@qq
L 1234567890 myQQ@qq.com

输出样例:

ERROR: Not Exist
New: OK
ERROR: Exist
ERROR: Wrong PW
Login: OK

 

 

 代码:

#include<iostream>
#include<map>
using namespace std;
map<long long,int>cz;
map<long long,string>mp;
int main(){
	int n; cin>>n;
	for(int i=0;i<n;i++){
		char op;long long x;string y;
		getchar();
		scanf("%c %lld",&op,&x); cin>>y;
		int d=y.length();
		if(op=='L'){
			if(!cz[x]) printf("ERROR: Not Exist\n");
			else if(mp[x]==y) printf("Login: OK\n");
			else printf("ERROR: Wrong PW\n");
		}
		else{
			if(cz[x]) printf("ERROR: Exist\n");
			else if(x>1000&&d>=6&&d<=16){
				printf("New: OK\n");
				cz[x]=1; mp[x]=y;
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值