Description
Write a program that reads in n integers and displays distinct numbers (ie., if a number appears multiple times, it is displayed only once).
Input
The first line is a positive integer t for the number of test cases.
Each test case contains two lines. The first line is an integer n (0<n<=100). The second line contains n integers.
Output
For each test case, outputs the distinct numbers in order in which they were read, seperated by one blank.
Sample Input
2
3
1 2 1
4
2 1 2 1
Sample Output
1 2
2 1
Code:
#include<stdio.h>
int main()
{
int CaseNum;
scanf("%d", &CaseNum);
int a[20][100];
int i, j, num[100];
for(i=0; i<CaseNum; i++){
scanf("%d", &num[i]);
for(j=0; j<num[i]; j++)
scanf("%d", &a[i][j]);
}
int k;
for(i=0; i<CaseNum; i++){
printf("%d", a[i][0]);
for(j=1; j<num[i]; j++){
for(k=0; k<j; k++){
if(a[i][k]==a[i][j])
break;
}
if(k==j)
printf(" %d", a[i][j]);
}
printf("\n");
}
return 0;
}