HDU 1570

http://acm.hdu.edu.cn/showproblem.php?pid=1570

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3391    Accepted Submission(s): 2179


Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.




Now I will give you n and m , and your task is to calculate the answer .
 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 

Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 

Sample Input
  
  
2 A 10 10 C 4 2
 

Sample Output
  
  
3628800 6
 
AC code:

#include <iostream>
using namespace std;
int main()
{
	char c;
	int n,m,i,s1,s2,s3,t;
	cin>>t;
	while(t--)
	{
		cin>>c>>n>>m;
		s1=1;
		s2=1;
		s3=1;
		for(i=1;i<=n;i++)
			s1*=i;
		for(i=1;i<=n-m;i++)
			s2*=i;
		if(c=='A')
		{
			
            cout<<s1/s2<<endl;
		}
		else if(c=='C')
		{
			for(i=1;i<=m;i++)
				s3*=i;
			cout<<s1/s2/s3<<endl;
		}


	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值