HDU:1260 Tickets(动态规划DP)

本文探讨了一种通过动态规划解决电影票售卖问题的方法,旨在帮助售票员尽可能早地完成工作。介绍了问题背景、解题思路及核心算法实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3268    Accepted Submission(s): 1619


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
  
  
2 2 20 25 40 1 8
 

Sample Output
  
  
08:00:40 am 08:00:08 am
 

Source
 

Recommend

JGShining


题目大意:一个人上班在售票机那里卖电影票,他可以一次取出一张电影票来卖给别人,也可以一次取出两张来卖给俩人,问这个人最早几点下班(即所有买票人都买完票了)。给了你k个人取票所用时间,k-1组两两组合后取票所用时间。

解题思路:动态规划,状态转移方程为dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]),即要么第i个人单独买,要么第i个人跟第i-1个人一起买。(上班时间是早上八点)

代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
int a[2010];
int b[2010];
int dp[2010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(dp,0,sizeof(dp));
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=2;i<=n;i++)
		{
			scanf("%d",&b[i]);
		}
		dp[1]=a[1];
		dp[2]=min(a[1]+a[2],b[2]);//前键 
		for(int i=3;i<=n;i++)
		{
			dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
		}
		int tmp=dp[n];
		int h=tmp/3600;
		int m=(tmp%3600)/60;
		int s=tmp%60;
		if(h+8>12)//下午输出pm,如下午一点  01:00:00 pm 
		{
			h=h+8;
			h=h-12;
			printf("%02d:%02d:%02d pm\n",h,m,s);//不够用零补充 
		}
		else
		{
			h=h+8;
			printf("%02d:%02d:%02d am\n",h,m,s);
		}
	}
	return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值