Dungeon Master POJ - 2251

本文介绍了一个3D迷宫逃脱问题的经典解决方法——使用广度优先搜索算法(BFS)。该算法能在最短时间内找到从起点到终点的路径。文章详细展示了如何通过C++实现这一算法,并提供了一个完整的代码示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45231 Accepted: 17070

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <sstream>
#include <map>

#define INF 10000
using namespace std;

int L,R,C;
char M[50][50][50];
int sx,sy,sz,ex,ey,ez;
struct DATA
{
	int x,y,z;
	int step;
	DATA()
	{
		step=0;
	}
};
typedef struct DATA DATA;
int dx[]={1,-1,0,0,0,0};
int dy[]={0,0,1,-1,0,0};
int dz[]={0,0,0,0,1,-1};
int vis[50][50][50];

int BFS()
{
	for(int i=0;i<L;i++)
	{
		for(int j=0;j<R;j++)
		{
			for(int k=0;k<C;k++)
			{
				if(M[i][j][k]=='S')
				{
					sx=i;
					sy=j;
					sz=k;
				}
				else if(M[i][j][k]=='E')
				{
					ex=i;
					ey=j;
					ez=k;
				}
			}
		}
	}
	DATA s;
	s.x=sx;
	s.y=sy;
	s.z=sz;
	vis[sx][sy][sz]=1;
	queue<DATA> Q;
	Q.push(s);
	while(Q.size()>0)
	{
		DATA cur=Q.front();
		Q.pop();
		int cx=cur.x;
		int cy=cur.y;
		int cz=cur.z;
		if(cx==ex&&cy==ey&&cz==ez)
		{
			return cur.step;
		}
		for(int k=0;k<6;k++)
		{
			int x=cx+dx[k];
			int y=cy+dy[k];
			int z=cz+dz[k];
			if(x>=0&&x<L&&y>=0&&y<R&&z>=0&&z<C&&vis[x][y][z]==0&&(M[x][y][z]=='.'||M[x][y][z]=='E'))
			{
				vis[x][y][z]=1;
				DATA tmp;
				tmp.x=x;
				tmp.y=y;
				tmp.z=z;
				tmp.step=cur.step+1;
				Q.push(tmp);
			}
		}
		
	}
	
	
	
	return -1;
}

int main()
{
	while(scanf("%d%d%d",&L,&R,&C)==3)
	{
		if(L==0 &&R==0 &&C==0) break;
		for(int i=0;i<L;i++)
		{
			for(int j=0;j<R;j++)
			{
				scanf("%s",M[i][j]);
			}
			getchar();
		}
		memset(vis,0,sizeof(vis));
		int ans=BFS();
		if(ans==-1)
		{
			printf("Trapped!\n");
		}
		else
		{
			printf("Escaped in %d minute(s).\n",ans);
		}
	}

	return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值