Layout
Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).
Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints. Input
Line 1: Three space-separated integers: N, ML, and MD.
Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart. Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input 4 2 1 1 3 10 2 4 20 2 3 3 Sample Output 27 Hint
Explanation of the sample:
There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27. Source |
差分约束可以转化为最短路:
对于d[i] <= d[i + 1] + 0 , 从顶点i+1向顶点i连一条权值为0的边。
对于d[AL] + DL >= d[BL] ,从顶点AL向顶点BL连一条权值为DL的边。
对于d[AD] <= d[BD] - DD , 从顶点BD向顶点AD连一条权值为 - DD的边。
然后进行Bellman —— Ford即可。
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 1000 + 50;
const int MAXS = 10000 + 50;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
const int inf = 1 << 30;
#define eps 1e-8
const int MOD = (int)1e9 + 7;
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pii;
#define Bug(s) cout << "s = " << s << endl;
///#pragma comment(linker, "/STACK:102400000,102400000")
int n , ml , md;
int AL[MAXS] , BL[MAXS], ML[MAXS];
int AD[MAXS] , BD[MAXS] , MD[MAXS];
int d[MAXN];
void solve()
{
fill(d , d + n , inf);
d[0] = 0;
for(int k = 0 ; k < n ; k++)
{
for(int i = 0 ; i < n - 1 ; i++)
{
if(d[i + 1] < inf)d[i] = min(d[i] , d[i + 1]);
}
for(int i = 0 ; i < ml ; i++)
{
if(d[AL[i] - 1] < inf)d[BL[i] - 1] = min(d[BL[i] - 1] , d[AL[i] - 1] + ML[i]);
}
for(int i = 0 ;i < md ; i++)
{
if(d[BD[i] - 1] < inf)d[AD[i] - 1] = min(d[AD[i] - 1] , d[BD[i] - 1] - MD[i]);
}
}
if(d[0] < 0)printf("-1\n");
else if(d[n - 1] == inf)printf("-2\n");
else printf("%d\n" , d[n - 1]);
}
int main()
{
while(~scanf("%d%d%d" , &n , &ml , &md))
{
for(int i = 0 ; i < ml ; i++)
{
scanf("%d%d%d" , &AL[i] , &BL[i] , &ML[i]);
}
for(int i = 0 ; i < md ; i++)
{
scanf("%d%d%d" , &AD[i] , &BD[i] , &MD[i]);
}
solve();
}
return 0;
}