M - Find a way HDU - 2612

 Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

题意:两个人找到可达的步数和最小的终点
思路:双向BFS
两次BFS
用两个数组存他们各自去每个位置需要的步数。
最后比较每个终点的步数和,找最小的那个
ps:最后判断的时候要判断path1和path2不能为0,为0是指至少有一个人不能到达终点

#include<iostream>
#include<cstdio>
#include<string.h>
#include<queue>
using namespace std;
int N,M;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
struct Pos{
    int x,y;
};
int path1[205][205];
int path2[205][205];
char mapp[205][205];
bool vis1[205][205];
bool vis2[205][205];
bool ok(int x,int y){
    return x>=0&&y>=0&&x<N&&y<M&&mapp[x][y]!='#';
}
void bfs(Pos pp,int id){
    queue<Pos>q;
    q.push(pp);
    if(id==1){
    while(!q.empty()){
        Pos tmp=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            int tx=tmp.x+dir[i][0];
            int ty=tmp.y+dir[i][1];

            if(!ok(tx,ty)||vis1[tx][ty]==1)continue;
            if(ok(tx,ty)&&vis1[tx][ty]==0){
                path1[tx][ty]=path1[tmp.x][tmp.y]+1;
                vis1[tx][ty]=1;
                Pos pp;
                pp.x=tx;pp.y=ty;
                q.push(pp);
                }
            }
        }

    }
    if(id==2){
    while(!q.empty()){
        Pos tmp=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            int tx=tmp.x+dir[i][0];
            int ty=tmp.y+dir[i][1];
            if(!ok(tx,ty)||vis2[tx][ty]==1)continue;
            if(ok(tx,ty)&&vis2[tx][ty]==0){
                path2[tx][ty]=path2[tmp.x][tmp.y]+1;
                vis2[tx][ty]=1;
                Pos pp;
                pp.x=tx;pp.y=ty;
                q.push(pp);
                    }
                }
            }
        }

return;
}
int main(){
    while(scanf("%d%d",&N,&M)!=EOF){
        Pos P1,P2;
        for(int i=0;i<N;i++)
        for(int j=0;j<M;j++){
            cin>>mapp[i][j];
            if(mapp[i][j]=='Y'){
                P1.x=i;
                P1.y=j;
            }
            if(mapp[i][j]=='M'){
                P2.x=i;
                P2.y=j;
            }
        }
        memset(vis1,0,sizeof(vis1));
        memset(vis2,0,sizeof(vis2));
        memset(path1,0,sizeof(path1));
        memset(path2,0,sizeof(path2));
        bfs(P1,1);
        bfs(P2,2);
        int ans=9999999;
        for(int i=0;i<N;i++)
        for(int j=0;j<M;j++){
        //特别注意path1和path2不能为0!!!!!!!!
            if(mapp[i][j]=='@'&&path1[i][j]!=0&&path2[i][j]!=0){
                ans=min(ans,path1[i][j]+path2[i][j]);

            }
        }
        cout<<ans*11<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值