poj3687 Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14868 Accepted: 4359

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source



题意:有T组测试数据,每组测试数据第一行有两个数n,m。代表有n个球,接下来m行,每行有两个数a,b,代表a球比b球轻,让你从小到大输出球的重量,若是相同重量,按照字典序输出。
题解:这个和以前的拓扑排序略微不同,不是考虑入度为0的情况。因为假设n为4,4<1.则输出的列是2,3,4,1,而不是按照以前所说的 4,1,2,3.所以要考虑的是先把最重的放在后面,轻的在前面按照字典序输出就可以了。
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int MAX = 210;
int map[MAX][MAX];
int indegree[MAX]; 
int n,m;
void topo(){
	int cnt = n;
	int sorted[MAX];
	priority_queue<int> q;
	for(int i = 1;i <= n; ++i){
		if(!indegree[i])
			q.push(i);
	}
	
	while(!q.empty()){
		int v= q.top();
		q.pop();
		sorted[v] = cnt--;
		for(int i = 1;i <= n; ++i){
			if(map[i][v]){
				if(!--indegree[i])
					q.push(i);
			}
		}
	}
	if(cnt > 0){
		cout<<"-1\n";
	}
	else{
		for(int i = 1;i <=n;++i)
			cout <<sorted[i] <<" ";
		cout <<endl;
	}
}

int main()
{
	int t;
	cin >> t;
	while(t--){
		cin >> n >> m;
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		int a, b;
		while(m--){
			cin >> a >> b;
			if(map[a][b]==0){
				map[a][b] =1;
				++indegree[a];
			}
		}
		topo();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值