hdu 2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13292    Accepted Submission(s): 5937


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!

源代码(二分查找)

//1000
#include<stdio.h>
#include<math.h>

double f(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}

int main()
{
    int t;
    double x1,x2,x3,y,y1,y2,y3;
    scanf("%d",&t);
    while(t--)
    {
        x1=0;
        x2=100;
        scanf("%lf",&y);
        y1=f(x1)-y;
        y2=f(x2)-y;
        if(y1>0||y2<0)
            printf("No solution!\n");
        else
        {
            while(fabs(f(x1)-f(x2))>=0.00001)
            {
                x3=(x1+x2)/2;
                y3=f(x3)-y;
                if(y3>0)
                   x2=x3;
                else
                   x1=x3;
                y1=f(x1)-y;
                y2=f(x2)-y;
            } 
            printf("%.4lf\n",x3);   
        }
        
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值