http://acm.hdu.edu.cn/showproblem.php?pid=1013
Digital Roots
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 32980 Accepted Submission(s): 10094
Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24 39 0
Sample Output
6 3
Source
这道题倒是很简单,不过有一个小陷阱,OJ使用的用例有可能是很大的整数,因此我选择使用字符数组存储整数,然后一个个处理;
代码:
#include<stdio.h>
#include<string.h>
int main(void)
{
int sum, i, root, length;
char a[1001];
while(scanf("%s", a) != EOF)
{
if(strcmp(a, "0") == 0)
break;
sum = 0;
length = strlen(a);
for(i = 0;i < length;i++)
{
sum += a[i] - '0';
}
root = 0;
while(sum > 0)
{
root += sum%10;
sum = sum/10;
if(root > 9 && !sum)
root = root%10 + root/10;
}
printf("%d\n", root);
}
return 0;
}