<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/zcs0237</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; zcs0237]]></copyright><item><title><![CDATA[UNIT16 Cisco知识]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9421833</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9421833</guid><author>zcs0237</author><pubDate>Tue, 23 Jul 2013 14:37:57 +0800</pubDate><description><![CDATA[※16.1常见路由协议总结
一、路由协议特性




1、有类：RIP V1、IGRP




2、水平分割、周期更新：RIP V1、RIP V2、IGRP




3、负载均衡：IGRP、EIGRP




4、分层设计：OSPF、IS-IS




5、cisco AD：R120、I100、D190、O110、IS115




6]]></description><category></category></item><item><title><![CDATA[UNIT15 Network Security Scanner]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9421659</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9421659</guid><author>zcs0237</author><pubDate>Tue, 23 Jul 2013 14:28:19 +0800</pubDate><description><![CDATA[扫描的目的就是利用各种工具对攻击目标的IP或地址段的主机查找漏洞及进行信息收集:安全管理员可以用来确保自己系统的安全性;黑客用来探查系统的入侵点。
一、网络扫描策略

1、被动式策略(不会对系统造成破坏)
基于主机之上，对系统中不合适的设置，脆弱的口令以及其他同安全规则抵触的对象进行检查。
2、主动式策略(进行模拟攻击，可能会对系统造成破坏)
是基于网络的，它通过执行一些脚本文件模拟对]]></description><category></category></item><item><title><![CDATA[UNIT14 TCP/IP Summary]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9421487</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9421487</guid><author>zcs0237</author><pubDate>Tue, 23 Jul 2013 14:19:24 +0800</pubDate><description><![CDATA[一、Protocol RM
1、OSI7层复杂复杂 PK TCP 3层简单
OSI每一层都要求可靠性，实现成本高，难获厂商支持。
TCP/IP没有OSI那么复杂，节省资源,没有OSI可靠。 
2、TCP/IP上下层关联






应用层


←端口←


传输层




传输层或应用层


←头标中Protocol字段←


网络层

]]></description><category></category></item><item><title><![CDATA[UNIT13 SSL HandShake]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9421271</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9421271</guid><author>zcs0237</author><pubDate>Tue, 23 Jul 2013 14:06:15 +0800</pubDate><description><![CDATA[13.1 SSL与TLS
最新版本的Transport Layer Security协议是Internet Engineering Task Force制定的一种新的协议，它建立在SSL 3.0协议规范之上，是SSL
 3.0的后续版本。
在TLS与SSL3.0之间存在着显著的差别，即它们所支持的加密算法不同，所以TLS与SSL3.0不能互操作。
一、TLS与SSL的差异
1、版本号
]]></description><category></category></item><item><title><![CDATA[UNIT12 Hyper Text Transfer Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9342321</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9342321</guid><author>zcs0237</author><pubDate>Tue, 16 Jul 2013 16:37:34 +0800</pubDate><description><![CDATA[起源于1960年美国人Ted Nelson文本信息处理的思想——hypertext，他被誉为HTTP之父。




RFC1945=HTTP1.0/1996年/描述：已过时,非持久连接,仅get, 
仅HTML格式。




RFC2068=HTTP1.1/1997年/初步描述：代理服务器还在用, 非持久连接, Get+Post+Head,MIME,带版本头。



]]></description><category></category></item><item><title><![CDATA[UNIT11 Multipurpose Internet Mail Extensions]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9342203</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9342203</guid><author>zcs0237</author><pubDate>Tue, 16 Jul 2013 14:05:24 +0800</pubDate><description><![CDATA[RFC2045、2046、2047、2048、2049MIME多用途互联网邮件扩展是互联网标准，它扩展了电子邮件标准，使其能够支持非ASCII字符、二进制格式附件等多种格式的邮件消息。

     由RFC 822转变而来的RFC 2822，规定电子邮件标准并不允许在邮件消息中使用7位ASCII字符集以外的字符。正因如此，一些非英语字符消息和二进制文件，图像，声音等非文字消息都不能在电子邮件中]]></description><category></category></item><item><title><![CDATA[UNIT10 Trivial File Transfer Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9342065</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9342065</guid><author>zcs0237</author><pubDate>Tue, 16 Jul 2013 13:59:10 +0800</pubDate><description><![CDATA[一、TFTP是一个很小且易于实现的文件传送协议
1、FTP的简化版本，没有一个庞大的命令集




不支持交互


1980年定义


占内存很小




不能列出目录


不能进行身份鉴别


只支持对文件进行读/写传输




2、停止/等待，C/S协议






①发送完一个文件块后就等待对方的确认，确认时应指明所确认的]]></description><category></category></item><item><title><![CDATA[UNIT09 FTP Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9340607</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9340607</guid><author>zcs0237</author><pubDate>Tue, 16 Jul 2013 11:40:49 +0800</pubDate><description><![CDATA[※09.1 FTP Protocol Overall
一、FTP Introduction
1、万维网出现以前用户使用命令行方式传输文件，最通用的就是FTP。经40年发展，FTP标准已从简单的基于TCP的网络文件复制协议转变成复杂的整合模式，能在包括云服务在内的不同环境中。






FRC 114/1971年/已废除，最初由 MIT学生Abhay Bhushan制定

]]></description><category></category></item><item><title><![CDATA[UNIT08 Secure SHell Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9340309</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9340309</guid><author>zcs0237</author><pubDate>Tue, 16 Jul 2013 11:00:47 +0800</pubDate><description><![CDATA[08.1 SSH Protocol Overall
一、SSH Introduction
1、Background
         SSH由IETF的Network Working Group所制定。最初的SSH协议是由芬兰的一家公司的研究员Tatu Ylnen于1995年设计开发的，但是因为受版权和加密算法等等的限制，现在很多人都转而使用OpenSSH。OpenSSH是SSH的替代软件包]]></description><category></category></item><item><title><![CDATA[UNIT07 Teletype over the Network]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9330587</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9330587</guid><author>zcs0237</author><pubDate>Mon, 15 Jul 2013 15:28:27 +0800</pubDate><description><![CDATA[※07.1 Telnet Protocol Overall
一、Telnet简介(帐号/密码和数据都是明文)
     telecommunication network protocol/Teletype over the Network是最老的Internet应用，起源于1969年的ARPANET。最常用的Telnet应用: Bulletin Board System。
1、telnet]]></description><category></category></item><item><title><![CDATA[UNIT06 User Datagram Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9330479</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9330479</guid><author>zcs0237</author><pubDate>Mon, 15 Jul 2013 12:02:10 +0800</pubDate><description><![CDATA[UDP在设计时的简单性是为了保证UDP工作时的高效和低延时，在服务质量较高的网络中(如局域网)，UDP可以高效地工作。
一、UDP协议的特点
1、 多路复用: UDP只在IP数据报之上增加了端口
      (IP地址在IP层才会封装到IP数据报的包头中)。


2、UDP端口用报文队列

UDP提供无连接的服务，每一个用户数据报都是独立的，用户数据报不使用编号，所以接收端无从排起]]></description><category></category></item><item><title><![CDATA[UNIT05 TCP SYN Flood]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9329643</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9329643</guid><author>zcs0237</author><pubDate>Mon, 15 Jul 2013 11:25:38 +0800</pubDate><description><![CDATA[05.1 SYN Flood Overall



一、产生背景
SYN Flood攻击是一种通过向目标服务器发送SYN报文，消耗其系统资源，削弱目标服务器的服务提供能力的行为。一般情况下，SYN Flood攻击是在采用IP源地址欺骗行为的基础上，利用TCP连接建立时的三次握手过程形成的。
众所周知，一个TCP连接的建立需要双方进行三次握手，只有当三次握手都顺利完成之后，一个TCP连接]]></description><category></category></item><item><title><![CDATA[UNIT04 Transfer Control Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9329189</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9329189</guid><author>zcs0237</author><pubDate>Mon, 15 Jul 2013 11:02:43 +0800</pubDate><description><![CDATA[基于连接：TCP确认机制、超时重发机制、流量控制机制

※04.1 TCP Complete Reliability

一、面向连接的传输Connection Orientation
     必须先在双方之间建立一个TCP连接(不支持广播)，之后才能传输数据,TCP连接的可靠建立—— 3次握手法。
三次握手法 就是在连接建立和终止过程中，通信的双方需要交换 3个报文。在数据包丢失、重]]></description><category></category></item><item><title><![CDATA[UNIT03 Internet Control Message Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9301911</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9301911</guid><author>zcs0237</author><pubDate>Thu, 11 Jul 2013 17:19:37 +0800</pubDate><description><![CDATA[03.1 ICMP Protocol Overall

 
一、ICMP简介(RFC792,1981)
IP缺少差错控制,缺少差错报告与处理机制辅助机制。ICMP报文在以下几种情况下发送:数据报不能到达目的地；网关已经失去缓存功能；网关能够引导主机在更短路由上发送。
1、ICMP本身是独立的协议

2、除ping、tracert、pathping外ICMP通常不由程序直接使用
3、]]></description><category></category></item><item><title><![CDATA[UNIT02 Internet Protocol]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9297531</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9297531</guid><author>zcs0237</author><pubDate>Thu, 11 Jul 2013 10:32:37 +0800</pubDate><description><![CDATA[ARP和RARP报文不被封装在IP数据报中，而ICMP和IGMP的数据则要封装在IP数据报中进行传输。由于IP协议在网络层中具有重要的地位，人们又将TCP/IP协议的网络层称为IP层。

※02.1 IP Protocol Overall
1、所有的TCP、UDP、ICMP及IGMP数据都以IP数据报格式传输

2、IP协议是点-点的网络层通信协议

3、IP协议是一种不可靠、无连接]]></description><category></category></item><item><title><![CDATA[UNIT01 TCP/IP Protocol Stack]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9296903</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9296903</guid><author>zcs0237</author><pubDate>Thu, 11 Jul 2013 09:55:03 +0800</pubDate><description><![CDATA[网络协议是网络中计算机与终端之间正确传送信息和数据的规范格式，包括三大要素：





语法:是数据和控制信息的结构和格式；




语义:是控制信息的含义；




时序/同步:是指双方相互应答的次序。





TCP/IP的IP协议是“尽力传递”方式，只有TCP层为保证传输可靠性而做必要的工作，不像OSI几乎每层都要保证可靠传输。
     实践]]></description><category></category></item><item><title><![CDATA[UNIT01 TCP/IP Protocol Stack]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9277835</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9277835</guid><author>zcs0237</author><pubDate>Tue, 09 Jul 2013 08:43:43 +0800</pubDate><description><![CDATA[网络协议是网络中计算机与终端之间正确传送信息和数据的规范格式，包括三大要素：





语法:是数据和控制信息的结构和格式；




语义:是控制信息的含义；




时序/同步:是指双方相互应答的次序。





TCP/IP的IP协议是“尽力传递”方式，只有TCP层为保证传输可靠性而做必要的工作，不像OSI几乎每层都要保证可靠传输。
       ]]></description><category></category></item><item><title><![CDATA[UNIT39 Shell level test]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9257875</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9257875</guid><author>zcs0237</author><pubDate>Sat, 06 Jul 2013 12:29:22 +0800</pubDate><description><![CDATA[一.OVERVIEW 篇
1. 有很多种 shell, 你熟悉几种？ 各个 shell 的 home page 在那里？
 
2. 为什么说 zsh 是目前为止功能最为强大的 shell.

3. 为什么说 pdksh 功能较弱？
 
4. ksh88 与 ksh93 有何区别？
 
5. 为什么 shell 编程最好用 ksh?
 
6. 你的系统都有哪些 shell? 版]]></description><category></category></item><item><title><![CDATA[UNIT38 awk常见应用]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9257837</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9257837</guid><author>zcs0237</author><pubDate>Sat, 06 Jul 2013 12:21:44 +0800</pubDate><description><![CDATA[一.awk 查看ip连接数
处理文本，是awk的强项了。 无论性能已经速度都是让人惊叹！ 
$ awk 'BEGIN{
    while("netstat -an"|getline){
        if( $5 ~ /[1-255]/)
        {
            split($5,t1,":");
            tarr[t1[1]]++;]]></description><category></category></item><item><title><![CDATA[UNIT37 awk Integrated case]]></title><link>https://blog.youkuaiyun.com/zcs0237/article/details/9257829</link><guid>https://blog.youkuaiyun.com/zcs0237/article/details/9257829</guid><author>zcs0237</author><pubDate>Sat, 06 Jul 2013 12:19:18 +0800</pubDate><description><![CDATA[filename为以下文件，第二列用“-”隔开，以避免与FS冲突




ID   Name      Age City Country Tel              Salary  Children
1001 Steven    25  NY   U.S.A   +01-02-323222    $4900   2
1002 Huang-Yu  30  BJ   CHN    ]]></description><category></category></item></channel></rss>