Wolf and Rabbit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6381 Accepted Submission(s): 3187
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2 1 2 2 2
Sample Output
NO YES
Author
weigang Lee
Source
Recommend
输入两个数,互质的话就是 no 否则 就是yes:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
__int64 m,n,i,j,k,l,x,y;
int ac(__int64 a,__int64 b)//辗转相除法
{
x=min(a,b);
y=max(a,b);
j=1;
while(j)
{
j=y%x;
y=x;
x=j;
}
return y;
}
int main()
{
scanf("%I64d",&k);
while(k--)
{
scanf("%I64d%I64d",&m,&n);
if(ac(m,n)==1)
printf("NO\n");
else
printf("YES\n");
}
}