Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 3508 Accepted Submission(s): 1364
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Take the sample output for more details.
Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
Sample Output
Case #1: Yes Case #2: No
Author
判断三角恋,第一行的意思就是0喜欢1,2,3,4;
第二行是1喜欢0;
第三行就是3喜欢1和4,依次类推:
附ac代码:
#include<stdio.h>
#include<string.h>
int topo[2020],i,n,m,j,k,l,t,map[2020][2020];
char c[2020][2020];
int main()
{
int biaoji=1;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
memset(topo,0,sizeof(topo));
for(i=0;i<n;i++)
scanf("%s",&c[i]);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
{
if(c[i][j]=='1')
topo[j]++;
}
int flag=0;
for(i=0;i<n;i++)
{
if(topo[i]==0)
{
topo[i]=1000;//经调试,如果i有三角恋关系类似的
for(j=0;j<n;j++)//则topo[i]一定减不到0
if(c[i][j]!='0')
topo[j]--;
flag++;//则flag+不到n
i=0;
}
}
printf("Case #%d: ",biaoji++);
if(flag==n)
printf("No\n");
else
printf("Yes\n");
}
return 0;
}