杭电4883 TIANKENG’s restaurant(小板凳的问题)

本文介绍了一种算法,用于计算在特定时间段内,餐厅为不同顾客群体提供服务所需的最小座位数。通过跟踪每组顾客到达和离开的时间,该算法能确保每位顾客都有座位,同时最大限度地减少所需座位的数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6
 
题目不再翻译   直接 看测试数据.
第一行输出的11 就是 说从八点到九点有六个人来吃饭,需要6个小板凳,8点89到9点59 有五个人吃饭 需要用5个小板凳,那么在8点59 分的时候  第一批的6个人还没有走,又来了5  个  所以 最少需要准备11个小板凳.
第二行输出的6 就是说 8点到9点 有六个人吃饭,9点到10点有5个人吃饭,但是第二批人吃饭的时候,第一批的6个刚好走,所以不需要额外的5个凳子,只需要6个就行了.
具体思路看代码.
#include<stdio.h>
#include<string.h>
long i,n,j,k,l,a[10001],x,y,z,rs,ks,js,w,bj,zz,zw,c;
int main()
{
	scanf("%ld",&c);
	while(c--)
	{
		scanf("%ld",&n);
		memset(a,0,sizeof(a));
		for(i=0;i<n;i++)
		{
		scanf("%ld%ld:%ld%ld:%ld",&rs,&x,&w,&k,&l);
		ks=x*60+w;//开始的地址 //时间 
		js=k*60+l;//结束的地址 //时间 
		for(j=ks;j<=js;j++)
		a[j]+=rs;//把数组开始到结束的值都等于   来的人 ,进行下次  循环,如果在  相同时间的时候  又来人,只需加上上次来的人 
		
		a[js]-=rs;//最后一分钟人要走,减去即可. 
		}
		long za=0;
		for(i=0;i<1440;i++)
		if(za<a[i])//从0 点开始  到  24点结束  每一分钟  都查找  找到  那一分钟  饭店人最多  输出即可 
		za=a[i];
		printf("%ld\n",za);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值