POJ 3187 (DFS)

本文介绍了一个有趣的数字游戏:从1到N的数字排列通过不断合并相邻数字直至只剩一个数。文章详细阐述了如何通过深度优先搜索算法来找出所有可能的数字排列,并筛选出符合特定总和条件的起始序列。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4 
 4   3   6 
 7   9 
 16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.



思路:

先利用深搜将1到n的排列枚举一下,然后在枚举的过程中判断是否满足条件,如果满足则直接回shu并打印出答案。注意输入格式,此题程序没有结束条件。

代码如下:

#include<cstdio>
#include<cstring>
int n,m;
int flag[20];
int num[20];
int a[20];
int i,ans;
int judge()
 {
 	int sum=n;
		for(i=0;i<n;i++)
		{
			a[i]=num[i];
		}
		while(sum>1)
		{
			for(i=0;i<sum-1;i++)
			{
				a[i]+=a[i+1];
			}
			sum--;
		}
		if(a[0]==m)
		{
			for(i=0;i<n-1;i++)
			{
				printf("%d ",num[i]);
			}
			printf("%d\n",num[n-1]);
			ans=1;
			return 0;
		}
 }
int dfs(int c)
{
	if(ans)
	return 0;
	if(c==n)
	{
		judge();
		return 0;
	}
	else
	{
		for(int i=1;i<=n;i++)
		{
			if(!flag[i])
			{
				flag[i]=1;
				num[c]=i;
				dfs(c+1);
				if(ans)
				return 0;
				flag[i]=0;
			}
		}
	}
 }

int main()
{
       scanf("%d%d",&n,&m);

       	    ans=0;
       	    dfs(0);
	   
	   return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值