PAT 1063. Set Similarity (25) 寻找交集。未解之谜。

本文介绍了一个计算两个整数集合相似度的问题,通过定义Nc为两个集合中共同拥有的不同整数的数量,Nt为两个集合中不同整数的总数,集合的相似度则为Nc/Nt*100%。文章提供了输入输出规范及一个具体的C++实现示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1063. Set Similarity (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%

33.3%

不懂为啥把那两行注释掉就过了。感觉应该没影响的。。。

#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#include<map>
#include<set>
#include<math.h>
#include<stack>
#include<vector>
using namespace std;

set<int> node[52];


void judge(int x,int y)
{
    set<int>::iterator it1=node[x].begin();
    set<int>::iterator it2=node[y].begin();
    int last=-1;
    int sum1=node[x].size()+node[y].size();
    int sum2=0;
    while(it1!=node[x].end()&&it2!=node[y].end())
      {
          if(*it1==*it2)
          {
              sum2++;
              //last=-1;
              it1++;
              it2++;
          }
          else if(*it1<*it2)
          {
           //  if(*it1==last) sum2++;    这两行一定要注释掉!!
             // last=*it1;
              it1++;
          }
          else { 
           //  if(*it2==last) sum2++;    这两行一定要注释掉!!
             // last=*it2;
              it2++;
                }
     }

  float tmp=(float)sum2/(float)(sum1-sum2);
             int zh=int(tmp*1000+0.5);
             int xx,yy,zz;
             xx=zh/100;
             yy=(zh%100)/10;
             zz=zh%10;
            if(xx!=0) cout<<xx;
            cout<<yy<<'.'<<zz<<'%'<<endl;

}


int main()
{
     int n,k;
     cin>>n;
    for(int i=1;i<=n;i++)
    {
        int tmp;
        scanf("%d",&tmp);
        for(int j=0;j<tmp;j++)
        {
            int tmmp;
            scanf("%d",&tmmp);
            node[i].insert(tmmp);
        }
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        int a1,b1;
        scanf("%d %d",&a1,&b1);
        judge(a1,b1);
    }


     return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值