UVA-133 The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input
Write a program that will successively read in(in that order)the three numbers(N, k and m; k,m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample Input
10 4 3
0 0 0

Sample Output
␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7

分析:两边的约瑟夫环问题。

Source:

#include<stdio.h>
int vis[20],n;
int move(int pos,int flag,int step)
{
    int i;
    for(i=1;i<=step;i++)
    {
        do{
            pos=(pos+flag+n-1)%n+1;        /*防止出现0和负数*/
        }while(vis[pos-1]);
    }
    return pos;
}
int main()
{
    int left,p1,p2;
    int k,m,i;
    while(scanf("%d%d%d",&n,&k,&m)!=EOF)
    {
        if(n==0&&k==0&&m==0)
            return 0;
        for(i=0;i<n;i++)
            vis[i]=0;
        p1=n;
        p2=1;
        left=n;
        while(left)
        {
            p1=move(p1,1,k);
            p2=move(p2,-1,m);
            left--;
            printf("%3d",p1);
            if(p1!=p2)
            {
                printf("%3d",p2);
                left--;
            }
            if(left)
                printf(",");
            else
                printf("\n");
            vis[p1-1]=vis[p2-1]=1;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值