Description
In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.
Here is a sample tiling of a 2x17 rectangle.

Input
Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output
For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.
Sample Input
2 8 12 100 200
Sample Output
3 171 2731 845100400152152934331135470251 1071292029505993517027974728227441735014801995855195223534251
题目意思明确了,由于是大数,用java写了。。
java里面注意一点,如果你要运算到第250个数,开数组必须要大于250,也就是从251开始
import java.util.*;
import java.io.BufferedInputStream;
import java.math.*;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner((System.in));
BigInteger[] f = new BigInteger[255];
f[0] = f[1] = BigInteger.ONE;
for (int i = 2; i <= 254; i++) {
f[i] = f[i - 1].add(f[i - 2].multiply(BigInteger.valueOf(2)));
}
int n;
while (cin.hasNext()) {
n = cin.nextInt();
System.out.println(f[n]);
}
}
}