算一个日期是星期几

F - What day is it
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Today is Saturday, 17th Nov,2007. Now, if i tell you a date, can you tell me what day it is ?
 

Input

There are multiply cases.
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
 

Output

Output one line.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
 

Sample Input

     
     
2007 11 17
 

Sample Output

     
     
Saturday
 

#include <iostream>

#include <cstring>
#include <string>
#include <math.h>
#include <algorithm>


using namespace std;


inline bool leap_year(int year)
{
    if((year%4==0&&year%100)||year%400==0) return 1;
    else return 0;
}


int main()
{
    int y,m,d;
    while(scanf("%d%d%d",&y,&m,&d)!=EOF)
    {
        int month[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
        if(leap_year(y)) month[2]=29;
        if(y<=0||m<=0||m>12||d<=0||d>month[m])
        {
            puts("illegal");
            continue;
        }
        int cnt=0;
        for(int i=4;i<y;i+=4)    //求y之前有多少个闰年
        if(leap_year(i)) cnt++;
        int sum=365*(y-1)+cnt;    //小技巧起大作用
        for(int i=1;i<m;i++)
        sum+=month[i];
        sum=(sum+d)%7;
        string day[7]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};
        cout << day[sum]<< endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值