Description
Today is Saturday, 17th Nov,2007. Now, if i tell you a date, can you tell me what day it is ?
Input
There are multiply cases.
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
Output
Output one line.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
Sample Input
2007 11 17
Sample Output
Saturday
#include <iostream>
#include <cstring>#include <string>
#include <math.h>
#include <algorithm>
using namespace std;
inline bool leap_year(int year)
{
if((year%4==0&&year%100)||year%400==0) return 1;
else return 0;
}
int main()
{
int y,m,d;
while(scanf("%d%d%d",&y,&m,&d)!=EOF)
{
int month[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
if(leap_year(y)) month[2]=29;
if(y<=0||m<=0||m>12||d<=0||d>month[m])
{
puts("illegal");
continue;
}
int cnt=0;
for(int i=4;i<y;i+=4) //求y之前有多少个闰年
if(leap_year(i)) cnt++;
int sum=365*(y-1)+cnt; //小技巧起大作用
for(int i=1;i<m;i++)
sum+=month[i];
sum=(sum+d)%7;
string day[7]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};
cout << day[sum]<< endl;
}
return 0;
}