、
Description
Given an array containing a permutation of 1 to n, you have to find the minimum number of swaps to sort the array in ascending order. A swap means, you can exchange any two elements of the array.
For example, let n = 4, and the array be 4 2 3 1, then you can sort it in ascending order in just 1 swaps (by swapping 4 and 1).
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains two lines, the first line contains an integer n (1 ≤ n ≤ 100). The next line contains n integers separated by spaces. You may assume that the array will always contain a permutation of 1 to n.
Output
For each case, print the case number and the minimum number of swaps required to sort the array in ascending order.
Sample Input
3
4
4 2 3 1
4
4 3 2 1
4
1 2 3 4
Sample Output
Case 1: 1
Case 2: 2
Case 3: 0
代码:
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
int a[105];
int main() {
int cas;
scanf("%d", &cas);
for (int t = 1; t <= cas; t ++) {
int n;
int sum = 0;
scanf("%d", &n);
for (int i = 1; i <= n; i ++)
scanf("%d", &a[i]);
for(int i = 1; i <= n; i ++) {
if(a[i] == i) continue;
for(int j = i; j <= n; j ++) {
if(a[j] == i) {
a[j] = a[i];
a[i] = i;
sum ++;
break;
}
}
}
printf("Case %d: %d\n",t, sum);
}
return 0;
}