HDU1896_Stones_stl的优先队列

本文介绍了一个基于石头位置和投掷距离的游戏算法问题。通过优先队列实现石头的处理逻辑,解决了一个角色在行走过程中根据石头的奇偶性进行投掷或保留的问题。最终输出角色经过后最远石头的位置。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2536    Accepted Submission(s): 1635


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11 12


#include<cstdio>
#include<queue>

struct Stone
{
	int p,d;
	friend operator<(const Stone& x,const Stone& y)
	{
		return (x.p==y.p)?(x.d>y.d):(x.p>y.p);//符号要相反
	}
}s;
int main()
{
	//freopen("in.txt","r",stdin);

	int cas,n;
	scanf("%d",&cas);
	while(cas--){

		std::priority_queue<Stone>qu;

		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d%d",&s.p,&s.d);
			qu.push(s);
		}

		int ans=0,i=1;
		while(!qu.empty()){

			if(i==1){
				s.d=qu.top().d,s.p=qu.top().p+s.d;
				qu.pop();
				qu.push(s);
			}
			else{
				if(ans<qu.top().p) ans=qu.top().p;
				qu.pop();
			}
			i*=-1;
		}

		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值