Legal or Not

本文介绍了一个算法问题,即如何通过编程判断在一个特定的QQ群中,成员之间建立的师生关系是否合法。考虑到可能存在非法的相互师生关系,文章提供了一段C++代码实现,用于检查输入的师生配对数据是否构成合法的单向师生关系。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO
#include<cstdio>
#include<iostream>
#include<cstring>
#include<map>
#include<string>
using namespace std;
typedef long long ll;
const ll maxn=505;
int m,n,vis[maxn],p[maxn][maxn];
void top()
{
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(!vis[j])
			{
				vis[j]--;
				//printf("%d",j);
				//if(i!=n) printf(" ");
				//else printf("\n");
				for(int k=0;k<n;k++)
				if(p[j][k]) vis[k]--;
				break;
			}
		}
	}
}
int main()
{
	
	while(cin>>n>>m&&n)
	{
		int flag=1;
		memset(p,0,sizeof(p));
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=m;i++)
		{
			int x,y;
			cin>>x>>y;
			if(!p[x][y])
			{
				p[x][y]=1;
				vis[y]++;
			}
		}
		top();
		for(int i=0;i<n;i++)
		{
			if(vis[i]>0)
			{
				cout<<"NO"<<endl;
				flag=0;
				break;
			}
		}
		if(flag)
		cout<<"YES"<<endl;
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值