暴搜+回溯 —— Sticks

Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8682    Accepted Submission(s): 2561


Problem Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero. 
 

Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
 

Output
The output file contains the smallest possible length of original sticks, one per line. 
 

Sample Input
  
  
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
 

Sample Output
  
  
6 5

题意:将n个数分成m堆,每一堆的和都相等为H,求H最小为多少。
题中有一些数字:
50:指剪后每一段绳子长度最大为50
64:指剪后绳子数量最大为64
还有注意,有可能有绳子根本就没有减


剪枝:

(1)剩余长度和当前长度相等时,停止搜索

(2)剩余长度等于绳子总长度,当前长度不符合,则停止搜索

(3)当前长度不符合条件,则相同的长度不再进行搜索


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int flag,n,maxn;
int used[100],a[100];
int cmp(int x,int y){
    return x>y;
}
void dfs(int ans,int num_k,int dd)
{
    if(flag==1) return ;
    if(num_k==n){
        flag=1;
        return ;
    }
    if(ans==0 && num_k<n)   dfs(maxn,num_k,0);
    
    for(int i=dd;i<n;i++){
        if(!flag && !used[i] && a[i]<=ans){
            used[i]=1;
            dfs(ans-a[i],num_k+1,dd);
            used[i]=0;
            if(ans==a[i])return ;
            if(ans==maxn)   return ;
            while(a[i]==a[i+1]) ++i ;
        }
    }
}
int main()
{
    while(~scanf("%d",&n)){
        if(n==0)    break;
        int sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+n,cmp);
        maxn=a[0];
        flag=0;
        while(!flag){
            while(sum%maxn!=0)
                ++maxn;
            memset(used,0,sizeof(used));
            dfs(maxn,0,0);
            if(flag)    break;
            ++maxn;
        }
        printf("%d\n",maxn);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值