poj 3468 A Simple Problem with Integers

本文介绍了一道关于整数操作的问题,并提供了一个使用线段树进行区间更新的解决方案。该问题要求处理一系列整数的加法和查询求和操作。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
   
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

解题思路:线段树区间更新模板题。
代码:
#include <iostream>
#define N 100005
#include <stdio.h>
using namespace std;
long long num[N];
struct Tree
{
    int l,r;long long sum;
    long long add;
}tree[N*4];
void PushUp(int root)
{
    tree[root].sum=tree[root<<1].sum+tree[root<<1|1].sum;
}
void PushDown(int root,int m)
{
    if(tree[root].add)
    {
        tree[root<<1].add+=tree[root].add;
        tree[root<<1|1].add+=tree[root].add;
        tree[root<<1].sum+=(m-(m>>1))*tree[root].add;
        tree[root<<1|1].sum+=(m>>1)*tree[root].add;
        tree[root].add=0;
    }
}
void build(int root,int l,int r)
{
    tree[root].l=l;
    tree[root].r=r;
    tree[root].add=0;
    if(tree[root].l==tree[root].r)
    {
        tree[root].sum=num[l];
        return;
    }
    int mid=(l+r)/2;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);
    PushUp(root);
}
void update(int L,int R,int c,int l,int r,int root)
{
    if(l>=L&&r<=R)
    {
        tree[root].add+=c;
        tree[root].sum+=(long long)c*(r-l+1);
        return ;
    }
    PushDown(root,r-l+1);
    int mid=(l+r)/2;
    if(mid>=L)
    update(L,R,c,l,mid,root<<1);
    if(mid<R)
    update(L,R,c,mid+1,r,root<<1|1);
    PushUp(root);
}
long long query(int L,int R,int l,int r,int root)
{
    if(L<=l&&R>=r)
    return tree[root].sum;
    PushDown(root,r-l+1);
    long long ret=0;
    int mid=(l+r)>>1;
    if(mid>=L) ret+=query(L,R,l,mid,root<<1);
    if(mid<R) ret+=query(L,R,mid+1,r,root<<1|1);
    return ret;
}
int main()
{
    int m,n;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    scanf("%I64d",&num[i]);
    build(1,1,n);
    while(m--)
    {
        char s[6];
        int a,b,c;
        scanf("%s",s);
        if(s[0]=='Q')
        {
            scanf("%d%d",&a,&b);
            printf("%I64d\n",query(a,b,1,n,1));
        }
        else
        {
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,1,n,1);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值