题目1841 Find the Shortest Common Superstring(KMP)

本文探讨了两个字符串的最短公共超字符串问题,并提供了一种通过KMP算法寻找最优解的方法。该算法能有效确定两个字符串组合成最短长度的新字符串,使其同时包含原始字符串作为子序列。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Find the Shortest Common Superstring

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1629    Accepted Submission(s): 437


Problem Description
The shortest common superstring of 2 strings S 1 and S 2 is a string S with the minimum number of characters which contains both S 1 and S 2 as a sequence of consecutive characters. For instance, the shortest common superstring of “alba” and “bacau” is “albacau”.
Given two strings composed of lowercase English characters, find the length of their shortest common superstring. 
 

Input
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S 1 and the second line contains the string S 2. Both of these strings contain at least 1 and at most 1.000.000 characters.
 

Output
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.
 

Sample Input
  
  
2 alba bacau resita mures
 

Sample Output
  
  
7 8
 

Author
Mugurel Ionut Andreica
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1801  1823  1427  1839  1582 
 
应该说很水的,就有考虑一下,一个串包含另一个串的情况就好了
ac代码


#include<stdio.h>
#include<string.h>
int next[1000100];
char ans[2000100],s1[1000100],s2[1000100];
void getnext(char *s,int len)
{
	next[0]=-1;
	int i,j;
	i=0;
	j=-1;
	while(i<=len)
	{
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
int kmp(char *a,char *b,int len1,int len2)
{	
//	memset(next,0,sizeof(next));
	getnext(b,len2);
	int i,j;
	i=j=0;
	while(i<len1)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
		if(j==len2)
			return len2;
	}
	if(i==len1)
		return j;
	return 0;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s",s1,s2);
		int len1=strlen(s1);
		int len2=strlen(s2);
		int x=kmp(s1,s2,len1,len2);
		int y=kmp(s2,s1,len2,len1);
		int ans;
		if(x>y)
		{
			ans=len1+len2-x;
		}
		else
		{
			ans=len1+len2-y;
		}
		printf("%d\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值