HDOJ 题目4349 Xiao Ming's Hope(找规律)

本篇介绍了一个有趣的数学问题:对于给定的n,计算组合数C(n,0)到C(n,n)中奇数的数量。通过将n转换为二进制并计算其中1的数量来快速得出答案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1515    Accepted Submission(s): 1015


Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C (n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers. When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
 

Input
Each line contains a integer n(1<=n<=10 8)
 

Output
A single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).
 

Sample Input
  
  
1 2 11
 

Sample Output
  
  
2 2 8
 

Author
HIT
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:   4340  4348  4347  4346  4345 
 
题意:求 C (n,0) ,C (n,1) ,C (n,2) ...C (n,n) .当中有多少个奇数。
就是n转化为二进制后又多少个1,就是2的多少次方
ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int cot(int x)
{
	int ans=0;
	while(x)
	{
		int temp=x%2;
		if(temp)
			ans++;
		x/=2;
	}
	return ans;
}
int qpow(int a,int b)
{
	int ans=1;
	while(b)
	{
		if(b&1)
			ans*=a;
		a*=a;
		b/=2;
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",qpow(2,cot(n)));
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值