Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 32374 Accepted Submission(s): 12441
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6HintIn the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
ac代码
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int main()
{
int n;int s,a,b,num;
scanf("%d",&n);
while(n--)
{
scanf("%d",&num);
a=num%10;
b=num%4;
if(b==0)
b=4;
printf("%d\n",(int)pow((double)a,b)%10);
}
}