1019 General Palindromic Number (20)

本文介绍了一种判断数字在特定进制下是否为回文数的方法,并提供了完整的C++实现代码。通过转换数字到指定进制并检查其是否正反相同来完成判别。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits a~i~ as the sum of (a~i~b^i^) for i from 0 to k. Here, as usual, 0 <= a~i~ < b for all i and a~k~ is non-zero. Then N is palindromic if and only if a~i~ = a~k-i~ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9^ is the decimal number and 2 <= b <= 10^9^ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "a~k~ a~k-1~ ... a~0~". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
思路:

输入一个数字和它的进制数,判断这个数字在这个进制下是否是回文数

注意:计算进制,一定要用do-while结构

C++:

#include "cstdio"
#include "iostream"
using namespace std;

int a[40];//储存回文的每一位
int index = 0;

//计算进制
void jinzhi(int x, int b){
	do
	{
		a[index++] = x%b;
		x /= b;
	}while (x!=0)//这里一定要用do while,否则有个测试点不过
}
//判断回文
bool huiwen(int h[]){
	for(int i = 0;i < index/2; i++){
		if(a[i] != a[index-i-1])return false;
	}
	return true;
}
int main(){
	int x,b;
	cin>>x>>b;
	jinzhi(x,b);
	if (huiwen(a))
	{
		cout<<"Yes"<<endl;
	}else
	{
		cout<<"No"<<endl;
	}
	for(int i = index - 1;i >= 0;i--){
		cout<<a[i];
		if (i != 0)
		{
			cout<<" ";
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值