标题:日期问题小明正在整理一批历史文献。这些历史文献中出现了很多日期。小明知道这些日期都在1960年1月1日至2059年12月31日。令小明头疼的是,这些日期采用的格式非常不统一,有采用年/月/日的,有采用月/日/年的,还有采用日/月/年的。更加麻烦的是,年份也都省略了前两位,使得文献上的一个日期,存在很多可能的日期与其对应。
比如02/03/04,可能是2002年03月04日、2004年02月03日或2004年03月02日。
给出一个文献上的日期,你能帮助小明判断有哪些可能的日期对其对应吗?
输入
----
一个日期,格式是"AA/BB/CC"。 (0 <= A, B, C <= 9)输入
----
输出若干个不相同的日期,每个日期一行,格式是"yyyy-MM-dd"。多个日期按从早到晚排列。样例输入
----
02/03/04样例输出
----
2002-03-04
2004-02-03
2004-03-02资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
请严格按要求输出,不要画蛇添足地打印类似:“请您输入...” 的多余内容。注意:
main函数需要返回0;
只使用ANSI C/ANSI C++ 标准;
不要调用依赖于编译环境或操作系统的特殊函数。
所有依赖的函数必须明确地在源文件中 #include <xxx>
不能通过工程设置而省略常用头文件。提交程序时,注意选择所期望的语言类型和编译器类型。
一开始用所以的判断用的都是字符,后来越来越复杂,就放弃了
这题有几个注意点,
1,闰年判断
2,排序
3,去重
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <sstream>
using namespace std;
typedef struct{
int year, month, day;
}date;
bool isyn(int y){
return (y % 4 == 0) || (y % 100 && y % 400 == 0);
}
string format(const date &d){
char ar[20];
sprintf(ar,"%02d-%02d-%02d",d.year,d.month,d.day);
return string(ar);
}
bool compare(const date &d1, const date &d2){
if(d1.year != d2.year){
return d1.year < d2.year;
}
if(d1.month != d2.month){
return d1.month < d2.month;
}
return d1.day < d2.day;
}
bool check(const date &d){
static int month_days[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
if(isyn(d.year)){
month_days[2] = 29;
}else{
month_days[2] = 28;
}
if(d.year < 1960 || d.year > 2059){
return false;
}
if(d.month < 1 || d.month > 12){
return false;
}
if(d.day < 1 || d.day > month_days[d.month]){
return false;
}
}
int main()
{
// freopen("input.txt","r",stdin);
int aa, bb, cc;
scanf("%d/%d/%d", &aa, &bb, &cc);
date d[6] = {
{2000 + aa, bb, cc},
{1900 + aa, bb, cc},
{2000 + cc, aa, bb},
{1900 + cc, aa, bb},
{2000 + cc, bb, aa},
{1900 + cc, bb, aa}
};
sort(d, d + 6, compare);
set<string> st;
for(int i = 0; i < 6; ++ i){
if(check(d[i])&&!st.count(format(d[i]))){
cout<<format(d[i])<<endl;
st.insert(format(d[i]));
}
}
return 0;
}
参考:
https://blog.youkuaiyun.com/luoluozlb/article/details/72806297
https://blog.youkuaiyun.com/wishchin/article/details/50824887