http://poj.org/problem?id=2488

本文介绍了一个经典的计算机科学问题——骑士周游问题,并提供了一种解决方案。该问题要求在一个缩小版的国际象棋棋盘上找到一条路径,使得骑士能够访问每一个方格恰好一次。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30733 Accepted: 10528

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
这个题我自作聪明了下,读入的时候,先读入y在读入x,按字典序输出没啥区别!就是wa呀!
换过来后就AC了!
草!
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int dir[8][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
bool visit[30][30];
int x, y;
struct node{
   int r,c;
}res[1000];
bool dfs(int a, int b, int step) {
    if (step == x*y) {
        for (int i = 0; i < step; i ++) {
            printf("%c%d", char(res[i].c+64), res[i].r);
        }
        printf("\n");
        return true;
    }

    int ax, by;
    for (int i = 0; i < 8; i ++) {
            ax = a+dir[i][0];
            by = b+dir[i][1];
            //cout << "ax =="<< ax <<endl;
            //cout << "by =="<< by <<endl;
        if (visit[ax][by] == false && ax >= 1 && ax <= x && by >= 1 && by <= y) {
            visit[ax][by] = true;
            res[step].r = ax;
            res[step].c = by;
            if (dfs(ax, by, step+1)) return true;
            visit[ax][by] = false;
        }
    }
return false;
}
int main() {
    int t;
    scanf("%d", &t);
    for (int i = 1; i <= t; i ++) {
        if (i != 1) printf("\n");
        scanf("%d%d", &x, &y);

        printf("Scenario #%d:\n", i);

        memset(visit, 0, sizeof(visit));
        visit[1][1] = true;
        res[0].r = 1;
        res[0].c = 1;
        if (!dfs(1, 1, 1)) printf("impossible\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值