Communication System
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20265 | Accepted: 7213 |
Description
We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.
Output
Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.
Sample Input
1 3 3 100 25 150 35 80 25 2 120 80 155 40 2 100 100 120 110
Sample Output
0.649
Source
Tehran 2002, First Iran Nationwide Internet Programming Contest
悲剧的贡献了N次wa...发现竟然是输入看错了...尼玛..输入不会换个行嘛...非得空格...话说这道题有dp的解法..
表示每次挑最小搜索的飘过..关键就是先qsort快排,然后每行挑出一个最小的,在搜索一遍大于这个宽带的price 坐标offset再偏移1个
话说我的方式 真心弱爆了。。。求大神指教..下面附题目以及代码...
#include <iostream>
#include <cstdio>
#include <cstdlib>
#define MAX 101
#define INF 99999
struct In
{
int x;
int y;
};
typedef struct In e;
int t,times;
e T[MAX][MAX],tmp[MAX];
//判断是否是尽头
bool examine()
{
for(int i=1;i<=times;i++)
if(T[i][0].x<=T[i][0].y)
return true;
return false;
}
int findMin()
{
int Min = INF;
int ord = 0;
for(int i=1;i<=times;i++)
{
if(T[i][T[i][0].x].x<Min&&T[i][0].x<=T[i][0].y)
{
Min = T[i][T[i][0].x].x;
ord = i;
}
}
return ord;
}
int cmp( const void *a ,const void *b)
{
return (*(In *)a).x > (*(In *)b).x ? 1 : -1;
}
using namespace std;
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d",×);
for(int i=1;i<=times;i++)
{
int companyNum;
scanf("%d",&companyNum);
for(int j=0;j<companyNum;j++)
{
scanf("%d",&tmp[j].x);
scanf("%d",&tmp[j].y);
}
qsort(tmp,companyNum,sizeof(tmp[0]),cmp);
for(int j=1;j<=companyNum;j++)
{
T[i][j] = tmp[j-1];
}
T[i][0].x = 1;
T[i][0].y=companyNum;
}
float ans = -INF;
while(examine())
{
int least = findMin();
int Sum = 0;
for(int i=1;i<=times;i++)
{
if(i==least)
{
Sum+=T[i][T[i][0].x].y;
continue;
}
else
{
int minPrice = INF;
for(int j=T[i][0].x;j<=T[i][0].y;j++)
{
if(T[i][j].y<minPrice)
minPrice = T[i][j].y;
}
Sum+=minPrice;
}
}
ans = max(ans,(float)T[least][T[least][0].x].x/(float)Sum);
T[least][0].x++;
}
printf("%.3f\n",ans);
}
return 0;
}