ZOJ--1091:Knight Moves(dfs)

该博客探讨了如何计算两个给定棋盘位置之间骑士移动的最短路径,这是一个与Traveling Knight Problem相关的子问题。作者通过DFS算法来解决这个问题,并提供了Java实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Knight Moves

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


思路:

这个题说骑士移动,其实就是象棋里的马走日字。(真的,这题里都没解释一下 让咱去梦呢?我是醉了)

剩下的就简单了 我是用dfs做

java:

import java.util.Scanner;

public class Knight_Moves_1091 {
	static String str1,str2;
	static int min,x,y,a,b;
	static int arr[]={2,2,-2,-2,1,1,-1,-1};
	static int brr[]={1,-1,1,-1,2,-2,2,-2};
	public static void main(String[] args) {
		Scanner s=new Scanner(System.in);
		while(s.hasNext()){
			str1=s.next();
			str2=s.next();
			x=str1.charAt(0)-'a'+1;
			a=str1.charAt(1)-'0';
			y=str2.charAt(0)-'a'+1;
			b=str2.charAt(1)-'0';
			min=20;      //这里的最小值不要定义太大 否则dfs太深 我第一次定义Integer.MAX 可想而知 第二次100还是超时 第三次50还超时 第四次20才可以了 你们还可以试试再小一点
			dfs(x,a,0);
			System.out.println("To get from "+str1+" to "+str2+" takes "+min+" knight moves.");
		}
	}
	public static void dfs(int xx,int yy,int moves){
		if(xx>8||xx<1||yy<1||yy>8||moves>=min)return;//min的作用就在这里 如果走的已经超过最小值就直接跳出
		if(xx==y&&yy==b){
			min=moves;
			return;
		}
		for(int i=0;i<8;i++){
			dfs(xx+arr[i],yy+brr[i],moves+1);
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值