POJ 3264 Balanced Lineup(RMQ/线段树)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 40312 Accepted: 18936
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source


     题意:给出一个数目为n的非有序的序列,然后m次查询,输入两个数l,r,输出闭区间[l,r]的最大值与最小值得差值。

思路;

    1.可以使用线段树做,线段树中的一个变量记录着一个区间的最大值,另一个变量记录着一个区间的最小值,然后输入l,r后,分别进行查询,最后得到的结果进行相减就是要求的值。

    2.也可以使用RMQ做,输入序列之后,进行预处理,然后每输入l,r后直接进行最大值和最小值的相减就可以了。



点击打开链接


线段树做法:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

using namespace std;

struct node{
    int l;
    int r;
    int xx;
    int yy;
}q[200010];

int n,m;

void build(int l,int r,int rt){
    q[rt].l = l;
    q[rt].r = r;
    if(l == r){
        scanf("%d",&q[rt].yy);
        q[rt].xx = q[rt].yy;
        return ;
    }
    int mid = (l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    q[rt].yy = min(q[rt<<1].yy,q[rt<<1|1].yy);
    q[rt].xx = max(q[rt<<1].xx,q[rt<<1|1].xx);
}

int qurry1(int ll,int rr,int l,int r,int rt){
    if(ll<=l && rr>=r){
        return q[rt].xx;
    }
    if(ll>r || rr<l){
        return 0;
    }
    int mid = (l+r)>>1;
    return max(qurry1(ll,rr,l,mid,rt<<1),qurry1(ll,rr,mid+1,r,rt<<1|1));
}

int qurry2(int ll,int rr,int l,int r,int rt){
    if(ll<=l && rr>=r){
        return q[rt].yy;
    }
    if(ll>r || rr<l){
        return 99999999;
    }
    int mid = (l+r)>>1;
    return min(qurry2(ll,rr,l,mid,rt<<1),qurry2(ll,rr,mid+1,r,rt<<1|1));
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        build(1,n,1);
        int x,y;
        for(int i=0;i<m;i++){
            scanf("%d%d",&x,&y);
            int maxx = qurry1(x,y,1,n,1);
            int minn = qurry2(x,y,1,n,1);
            printf("%d\n",maxx-minn);
        }
    }
    return 0;
}




RMQ做法:


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>

using namespace std;

const int N = 200010;
int maxx[N][20];
int minn[N][20];
int n,m;

void play(){
    int l = floor(log10(double(n))/log10(double(2)));
    for(int j=1;j<=l;j++){
        for(int i=1;i<=n+1-(1<<j);i++){
            maxx[i][j] = max(maxx[i][j-1],maxx[i+(1<<(j-1))][j-1]);
            minn[i][j] = min(minn[i][j-1],minn[i+(1<<(j-1))][j-1]);
        }
    }
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        int x,y;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            maxx[i][0] = x;
            minn[i][0] = x;
        }
        play();
        while(m--){
            scanf("%d%d",&x,&y);
            int pp = floor(log10(double(y-x+1))/log10(double(2)));
            printf("%d\n",max(maxx[x][pp],maxx[y-(1<<pp)+1][pp]) - min(minn[x][pp],minn[y-(1<<pp)+1][pp]));

        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值