hduoj1544(判断连续回文)

Palindromes

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1509 Accepted Submission(s): 712

Problem Description
A regular palindrome(回文) is a string of numbers or letters that is the same forward as backward. For example, the string “ABCDEDCBA” is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

Now give you a string S, you should count how many palindromes in any consecutive substring of S.

Input
There are several test cases in the input. Each case contains a non-empty string which has no more than 5000 characters.

Proceed to the end of file.

Output
A single line with the number of palindrome substrings for each case.

Sample Input

aba
aa

Sample Output

4
3
题解:从某一个开始,然后分偶数和奇数向左向右扩展,遇到不相等就退出,用二维dp会超时。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[5005];
bool dp[5005][5005];
int main(){
    int len,i,j,cnt,l,r;
    while(scanf("%s",str)!=EOF){

        len=strlen(str);
            cnt=len;
        for(i = 0 ; i < len ; i++){
            l=i-1;
            r=i+1;
            while(l>=0&&r<len&&str[l]==str[r]){
                l--;r++;
                cnt++;
            }
            l=i;r=i+1;
            while(l>=0&&r<len&&str[l]==str[r]){
                l--;r++;
                cnt++;
            }           
        }
        printf("%d\n",cnt);
        //cout<<cnt<<endl;
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值