Zipper

本文介绍了一个字符串问题:如何判断第三个字符串是否能由前两个字符串按原顺序交替组合而成。通过一个递归深度优先搜索算法实现,并提供了完整的C++代码示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 

#include<iostream>
using namespace std;
bool dp[201][201];//记忆化搜索,存储该状态是否检索过
char fir[201],sec[201],thi[402];
int n,firLen,secLen,thiLen;
bool isOk;
void dfs(int i,int j,int k){
    if(k==thiLen){
        isOk=true;
        return;
    }
    if(isOk)return ;//已经找到,直接跳出
    
    if(dp[i][j])return;//该状态搜索过直接跳出
    
    if(i<firLen&&fir[i]==thi[k])
        dfs(i+1,j,k+1);
    if(j<secLen&&sec[j]==thi[k])
        dfs(i,j+1,k+1);
    
    dp[i][j]=true;//做上标记,表明此状态扩展开的dfs都搜过了
    
}

int main(){
    while(scanf("%d",&n)!=EOF){
    for(int i=1;i<=n;i++){
        isOk=false;
        memset(dp,false,sizeof(dp));
        scanf("%s%s%s",fir,sec,thi);

        firLen=strlen(fir);
        secLen=strlen(sec);
        thiLen=strlen(thi);

        dfs(0,0,0);
        cout<<"Data set "<<i<<": ";
        cout<<(isOk?"yes":"no")<<endl;
    }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值