LA 3708 - Graveyard (数学几何&技巧)

3708 - Graveyard

Programming contests became so popular in the year 2397 that the governor of New Earck — thelargest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM)at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famouscontestants placed equidistantly along the park perimeter. The alley has to be renewed from time totime when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM,but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believethe holograms are holding dead people souls, and thus always try to renew the ACM with minimalpossible movements of existing statues (besides, the holographic equipment is very heavy). Statues aremoved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of traveldistances of all statues. Installation of a new hologram adds no distance penalty, so choose the placesfor newcomers wisely!

Input

The input file contains several test cases, each of them consists of a a line that contains two integernumbers: n — the number of holographic statues initially located at the ACM, and m — the numberof statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeteris exactly 10 000 feet.

Output

For each test case, write to the output a line with a single real number — the minimal sum of traveldistances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.Note:Pictures show the first three examples. Marked circles denote original statues, empty circles denotenew equidistant places, arrows denote movement plans for existing statues.

Sample Input

2 1

2 3

3 1

10 10

Sample Output

1666.6667

1000.0

1666.6667

0.0

#include<stdio.h>
#include<string.h>
#include<math.h> 
#include<algorithm>
#define ll long long
#define N 10010
using namespace std;
int main()
{
	int n,m,i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		double ans=0.0;
		for(i=1;i<n;i++)
		{
			double p=(double)i/n*(n+m);
			ans+=fabs(p-floor(p+0.5))/(n+m);
		}
		printf("%.4lf\n",ans*10000);
	} 
	return 0;
}


 

Vivado2023是一款集成开发环境软件,用于设计和验证FPGA(现场可编程门阵列)和可编程逻辑器件。对于使用Vivado2023的用户来说,license是必不可少的。 Vivado2023的license是一种许可证,用于授权用户合法使用该软件。许可证分为多种类型,包括评估许可证、开发许可证和节点许可证等。每种许可证都有不同的使用条件和功能。 评估许可证是免费提供的,让用户可以在一段时间内试用Vivado2023的全部功能。用户可以使用这个许可证来了解软件的性能和特点,对于初学者和小规模项目来说是一个很好的选择。但是,使用评估许可证的用户在使用期限过后需要购买正式的许可证才能继续使用软件。 开发许可证是付费的,可以永久使用Vivado2023的全部功能。这种许可证适用于需要长期使用Vivado2023进行开发的用户,通常是专业的FPGA设计师或工程师。购买开发许可证可以享受Vivado2023的技术支持和更新服务,确保软件始终保持最新的版本和功能。 节点许可证是用于多设备或分布式设计的许可证,可以在多个计算机上安装Vivado2023,并共享使用。节点许可证适用于大规模项目或需要多个处理节点进行设计的用户,可以提高工作效率和资源利用率。 总之,Vivado2023 license是用户在使用Vivado2023时必须考虑的问题。用户可以根据自己的需求选择合适的许可证类型,以便获取最佳的软件使用体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值