hdu 1162 Eddy's picture

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5025    Accepted Submission(s): 2478


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 

Author
eddy
 

Recommend
JGShining
 
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;

struct point//建立点类型
{
    double x,y;
} p[110];
int set[110];//最小生成树典型模式
struct dis//记录两点距离
{
    int s,e;//s开始点,e结束点
    double d;
} pd[110*109/2];
double cdis(point a,point b)//计算两点间距离的函数
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int cmp(dis a,dis b)//排序判断函数
{
    return a.d<b.d;
}
int root(int s)
{
    int j,t,i=s;
    while(set[i]!=i)
        i=set[i];
    j=s;
    while(j!=i)
    {
        t=set[j];
        set[j]=i;
        j=t;
    }
    return i;
}
int toone(int a,int b)
{
    int r1,r2;
    r1=root(a);
    r2=root(b);
    if(r1==r2)
        return 0;
    set[r2]=r1;
    return 1;
}
int main()
{
    int n,i,j,c;
    double tdis;
    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++)
            set[i]=i;
        c=0;
        tdis=0;
        for(i=0;i<n;i++)
            scanf("%lf%lf",&p[i].x,&p[i].y);
        for(i=0;i<n-1;i++)
            for(j=i+1;j<n;j++)
            {
                pd[c].s=i;
                pd[c].e=j;
                pd[c].d=cdis(p[i],p[j]);//记录两点间距离
                c++;
            }
        sort(pd,pd+c,cmp);
        for(i=0;i<c;i++)
           if(toone(pd[i].s,pd[i].e))
            tdis+=pd[i].d;//存最小总距离
        printf("%.2lf\n",tdis);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值