【算法笔记第9.6节-并查集】问题 D: More is better

王老师需要组建一个项目团队,团队成员越多越好。共有10000000名男孩,他们之间存在直接的朋友关系。给定直接朋友对,任务是确定王老师能保留的最大男孩数量,确保所有保留的男孩间都是朋友关系。输入包含朋友对的数量n和每个朋友对的A、B,输出最大保留人数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入

3
1 3
1 5
2 5
4
3 2
3 4
1 6
2 6

样例输出

4
5

题目说的是现在有一个项目需要一个队伍完成,而且队伍人数越多越好。

现在有10000000个人,给你一些两人之间的联系,让你输出队伍人数最多的人的数量。

#include<stdio.h>
#include<string.h>
int f[10000001];
int num[10000001];
int findFather(int x)
{
    if(x==f[x]) return x;
    else
    {
        int F = findFather(f[x]);
        f[x] = F;
        return F;
    }
}
void Union(int a, int b)
{
    int fa = findFather(a);
    int fb = findFather(b);
    if(fa!=fb)
        f[fa] = fb;
}
int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        memset(num, 0, sizeof(num));
        for(int i=1; i<=10000000; i++)
            f[i] = i;
        int a, b;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a, &b);
            Union(a, b);
        }
        int ans = 0;
        for(int i=1; i<=10000000; i++)
        {
            num[findFather(i)]++;
        }
        int maxn = 1;
        for(int i=1; i<=10000000; i++)
        {
            if(maxn < num[i])
                maxn = num[i];
        }
        printf("%d\n", maxn);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值