题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016点击打开链接
Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 52323 Accepted Submission(s): 23157
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source
基础深搜
线性筛
#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int prime[44];
int a[22];
int book[22];
int n=0;
void getprime()
{
for(int i=2;i<20;i++)
{
if(prime[i]==0)
for(int j=i+i;j<40;j+=i)
prime[j]=1;
}
prime[1]=1;
}
void dfs(int temp)
{
if(temp==n)
{
if(!prime[a[temp-1]+1])
{
for(int i=0;i<n-1;i++)
printf("%d ",a[i]);
printf("%d",a[n-1]);
printf("\n");
}
return ;
}
for(int i=2;i<=n;i++)
if(!book[i]&&!prime[a[temp-1]+i])
{
a[temp]=i;
book[i]=1;
dfs(temp+1);
book[i]=0;
}
}
int main()
{
getprime();
int step=1;
while(cin >> n)
{
memset(book,0,sizeof(book));
printf("Case %d:\n",step++);
a[0]=1;
dfs(1);
printf("\n");
}
}