HDU 1321 Reverse Text

Reverse Text

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6876    Accepted Submission(s): 3833


Problem Description
In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text. 
 

Input
The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.
 

Output
For each test case, print a line containing the characters of the input line in reverse order.
 

Sample Input
  
  
3 Frankly, I don't think we'll make much money out of this scheme. madam I'm adam
 

Sample Output
  
  
hcum ekam ll'ew kniht t'nod I ,ylknarF .emehcs siht fo tuo yenom mada m'I madam
 
题目大意:
就是说大多数人都是从左到右看文章的,但是这里有些文章都是从左到右写的,那么请你写个程序,将其翻译成原版的文章;
分析:
也就是要我们写个能够把正常的文章反过去的程序,那么我们只要反着遍历就OK了; 程序很简单,但是可以作为模板方便以后处理哪些需要反向操作的程序;

给出AC代码:
#include<iostream>
#include<string>
using namespace std;

int main()
{
	int n;
	cin >> n;
	getchar();
	string str;
	while (n--)
	{
		getline(cin, str);
		int len = str.length();
		for (int i = len - 1; i >= 0; i--)
			cout << str[i];
		cout << endl;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值