hdu5924Mr. Frog’s Problem+打表

博客描述了一个有趣的数学问题:在数学课上睡着并梦到由Mr. Frog提出的一个数学挑战,即找到所有符合条件的整数对(C, D),使得A/B+B/A≤C/D+D/C,并给出了具体的输入输出样例及源代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.

He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤B and A/B+B/A≤C/D+D/C

Input
first line contains only one integer T (T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤1018).

Output
For each test case, first output one line “Case #x:”, where x is the case number (starting from 1).

Then in a new line, print an integer s indicating the number of pairs you find.

In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.

Sample Input

2
10 10
9 27

Sample Output

Case #1:
1
10 10
Case #2:
2
9 27
27 9

Source
2016CCPC东北地区大学生程序设计竞赛 - 重现赛

ACB,ADB.andAB+BACD+DC
直接打了个表。发现A==B的时候只有一个A,B其他情况有两个A,B和B,A

#include<bits/stdc++.h>
using namespace std;
#define LL long long
int main(){
    LL t,A,B;
    cin>>t;
    for(int cas=1;cas<=t;cas++){
        cin>>A>>B;
        cout<<"Case #"<<cas<<":"<<endl;
        if(A==B){
            cout<<1<<endl;
            cout<<A<<" "<<B<<endl;
        }
        else {
            cout<<2<<endl;
            cout<<A<<" "<<B<<endl;
            cout<<B<<" "<<A<<endl;
        }
        /*double ans=(double)A/B+(double)B/A;
        for(int i=A;i<=B;i++){
            for(int j=A;j<=B;j++){
                double temp=(double)i/j+(double)j/i;
                if(temp>=ans){
                    cout<<i<<" "<<j<<endl;
                }
            }
        }
        cout<<"over"<<endl;*/
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值