Problem Description
One day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.
He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤B and A/B+B/A≤C/D+D/C
Input
first line contains only one integer T (T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤1018).
Output
For each test case, first output one line “Case #x:”, where x is the case number (starting from 1).
Then in a new line, print an integer s indicating the number of pairs you find.
In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.
Sample Input
2
10 10
9 27
Sample Output
Case #1:
1
10 10
Case #2:
2
9 27
27 9
Source
2016CCPC东北地区大学生程序设计竞赛 - 重现赛
A≤C≤B,A≤D≤B.andAB+BA≤CD+DC
直接打了个表。发现A==B的时候只有一个A,B其他情况有两个A,B和B,A
#include<bits/stdc++.h>
using namespace std;
#define LL long long
int main(){
LL t,A,B;
cin>>t;
for(int cas=1;cas<=t;cas++){
cin>>A>>B;
cout<<"Case #"<<cas<<":"<<endl;
if(A==B){
cout<<1<<endl;
cout<<A<<" "<<B<<endl;
}
else {
cout<<2<<endl;
cout<<A<<" "<<B<<endl;
cout<<B<<" "<<A<<endl;
}
/*double ans=(double)A/B+(double)B/A;
for(int i=A;i<=B;i++){
for(int j=A;j<=B;j++){
double temp=(double)i/j+(double)j/i;
if(temp>=ans){
cout<<i<<" "<<j<<endl;
}
}
}
cout<<"over"<<endl;*/
}
return 0;
}