
Accept: 9 Submit: 11
Time Limit: 1000 mSec Memory Limit : 262144 KB
Problem Description
Therearex frogs and y chicken in a garden. Kim found there are n heads and m legs in the garden. Please tell Kim how many frogs and chicken are there. (A frog has 4 legs, and a chicken has 2 legs.)
Input
First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.
For each test case: Two number n and m.
1<=n, m <=100000. The data is legal.
Output
For each test case, output two numbers A and B – the number of frog and the number of chicken.
Sample Input
2
2 6
2 4
Sample Output
1 1
0 2
Source
第八届福建省大学生程序设计竞赛-重现赛(感谢承办方厦门理工学院)
鸡兔同笼问题 解一个二元一次方程组就OK
#include<stdio.h>
using namespace std;
int main()
{
int t,n,m;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
int xf=(m-2*n)/2;
printf("%d ",xf);
printf("%d\n",n-xf);
}
return 0;
}