1809: Parenthesis
Time Limit: 5 Sec Memory Limit: 128 MBSubmit: 589 Solved: 142
[ Submit][ Status][ Web Board]
Description
Bobo has a balanced parenthesis sequence P=p
1 p
2…p
n of length n and q questions.
The i-th question is whether P remains balanced after p
ai and p
bi swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1.
S is empty;
2.
or there exists
balanced parenthesis sequence A,B such that S=AB;
3.
or there exists
balanced parenthesis sequence S' such that S=(S').
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10
5,1≤q≤10
5).
The second line contains n characters p
1 p
2…p
n.
The i-th of the last q lines contains 2 integers a
i,b
i (1≤a
i,b
i≤n,a
i≠b
i).
Output
For each question, output "
Yes" if P remains balanced, or "
No" otherwise.
Sample Input
4 2
(())
1 3
2 3
2 1
()
1 2
Sample Output
No
Yes
No
HINT
Source
http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1809
湖南省赛心都碎了
给你一个(平衡)的一些括号 问你随便调换两个位置的括号能不能再平衡
刚开始暴力了 每次调换 检验一次遇到 ( ++ )-- 一旦-1打断 还是TE了
所以觉得有规律 比赛时找了几个小时规律 还是没找到
竟然是线段树 省时间啦 还是找到一点规律
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define LL 100010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
int tree[LL*4],ans[LL];
int flag;
void pushup(int rt)
{
if(tree[rt<<1|1]==1||tree[rt<<1]==1)
tree[rt]=1;
}
void build(int l,int r,int rt)
{
tree[rt]=0;
if(l==r)
{
if(ans[l-1]<2)
tree[rt]=1;
return ;
}
int m=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void query(int L,int R,int l,int r,int rt)
{
if(flag) return ;
if(L<=l&&R>=r)
{
if(tree[rt])
{
flag=1;
}
return ;
}
int m=(l+r)>>1;
if(L<=m) query(L,R,lson);
if(R>m) query(L,R,rson);
}
int main()
{
char str[100010];
int a,b,n,m,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
scanf("%s",str);
ans[0]=1;
for(i=1; i<n; i++)
if(str[i]=='(')
ans[i]=ans[i-1]+1;
else ans[i]=ans[i-1]-1;
build(1,n,1);
for(int i=0; i<m; i++)
{
scanf("%d%d",&a,&b);
if(a>b)
swap(a,b);
if(str[a-1]==str[b-1])
{
printf("Yes\n");
continue;
}
if(str[a-1]==')') //这样必然可以
{
printf("Yes\n");
continue;
}
flag=0;
query(a,b-1,1,n,1);//查询区间里有没有<2的
if(!flag) printf("Yes\n");//如果有 把)换到前面去一定会导致这个区间都减掉2
else printf("No\n");
}
}
return 0;
}