1088. Rational Arithmetic (20)——PAT (Advanced Level) Practise

本文介绍了一个简单的分数算术运算实现方案,包括加、减、乘、除四种基本运算,并确保输出结果为最简形式。该算法使用C++实现,考虑了负数和零分母等特殊情况。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目信息

1088. Rational Arithmetic (20)

时间限制200 ms
内存限制65536 kB
代码长度限制16000 B
For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format “a1/b1 a2/b2”. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is “number1 operator number2 = result”. Notice that all the rational numbers must be in their simplest form “k a/b”, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output “Inf” as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:
2/3 -4/2
Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
Sample Input 2:
5/3 0/6
Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

解题思路

注意细节即可

AC代码

#include <iostream>
#include <string>
#include <sstream>
using namespace std;

long long gcd(long long a,long long b){
    return b != 0 ? gcd(b, a%b) : a;
}

string f(long long a,long long b){
    if(a==0)
        return "0";
    stringstream ss;
    string s;
    int flag=1;
    if(a<0){
        flag=-1;
        a=-a;
        ss<<"(-";
    }
    long long tmp=gcd(a,b);
    a=a/tmp;
    b=b/tmp;
    if(a%b==0){
        ss<<a/b;
    }else if(a/b>0){
        ss<<a/b<<" ";
        ss<<a%b<<"/"<<b;
    }else{
        ss<<a<<"/"<<b;
    }
    if(flag==-1)
        ss<<")";
    getline(ss,s);
    return s;
}
int main(){
    long a1,b1,a2,b2;
    scanf("%ld/%ld %ld/%ld",&a1,&b1,&a2,&b2);
    long long sum1,sum2,sub1,sub2,mul1,mul2,div1,div2;
    sum1=a1*b2+a2*b1;
    sum2=b1*b2;
    sub1=a1*b2-a2*b1;
    sub2=b1*b2;
    mul1=a1*a2;
    mul2=b1*b2;
    string s1=f(a1,b1);
    string s2=f(a2,b2);
    cout<<s1<<" + "<<s2<<" = "<<f(sum1,sum2)<<endl;
    cout<<s1<<" - "<<s2<<" = "<<f(sub1,sub2)<<endl;
    cout<<s1<<" * "<<s2<<" = "<<f(mul1,mul2)<<endl;
    cout<<s1<<" / "<<s2<<" = ";
    if(a2==0){
        cout<<"Inf";
    }else{
        div1=a1*b2;
        div2=b1*a2;
        if((div1<0&&div2<0)||(div1>0&&div2<0)){
            div1=-div1;
            div2=-div2;
        }
        cout<<f(div1,div2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值