1105. Spiral Matrix (25)

本文介绍了一种算法,该算法能够将一系列正整数按非递增顺序填充到螺旋矩阵中。螺旋矩阵从左上角开始,沿顺时针方向填充。文章详细说明了输入输出规范,并提供了一个具体的示例来帮助理解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;

bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    int N;
    cin>>N;
    int num[N+10];
    int ans[N+10][N+10];
    for(int i=0;i<N;i++)
    {
        cin>>num[i];
    }
    if(N==1)
    {
        printf("%d",num[0]);
        return 0;
    }
    sort(num,num+N,cmp);
    int m=(int)ceil(sqrt(1.0*N));
    while(N%m!=0)
    {
        m++;
    }
    int n=N/m,i=1,j=1,now=0;
    int u=1,d=m,l=1,r=n;
    while(now<N)
    {
        while(now<N && j<r)
        {
            ans[i][j]=num[now++];
            j++;
        }
        while(now<N && i<d)
        {
            ans[i][j]=num[now++];
            i++;
        }
        while(now<N && j>l)
        {
            ans[i][j]=num[now++];
            j--;
        }
        while(now<N && i>u)
        {
            ans[i][j]=num[now++];
            i--;
        }
        u++,d--,l++,r--;
        i++,j++;
        if(now==N-1)
        {
            ans[i][j]=num[now++];
        }
    }
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            printf("%d",ans[i][j]);
            if(j<n)
            {
                printf(" ");
            }
            else
            {
                printf("\n");
            }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值