1092 To Buy or Not to Buy (20 分)

本文介绍了一个算法,用于帮助用户Eva在商店中找到符合需求的珠串。算法通过比较商店珠串与目标珠串的颜色数量,判断是否需要额外购买珠子或缺少珠子,并输出相应数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s1,s2;
    int sum=0,v[1005]={0};
    cin>>s1>>s2;
    int len1=s1.length();
    int len2=s2.length();
    for(int i=0;i<len1;i++)
        v[s1[i]]++;
    for(int i=0;i<len2;i++)
    {
        if(v[s2[i]]>0)
            v[s2[i]]--;
        else
            sum++;
    }
    if(sum==0)
        cout<<"Yes "<<len1-len2;
    else
        cout<<"No "<<sum;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值